ESP32 - DOIT Dev Kit1 - Restart Loop

Library added and configured, Compiles fine within PlatformIO.
Error Message:
ets Jun 8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:1044
load:0x40078000,len:8896
load:0x40080400,len:5828
entry 0x400806ac

Reboots at several times a second. Timestamp doesn’t appear to change.

Attempted so far:

  • 2 Different DOIT Dev Kit1s-ESP-WROOM - Same Behaviour on both.
  • First configured with SD Reader , Second Without SD Reader or anything connected.
  • Powered Via USB and Via Mains.
  • Powered Via 5V & 3.3V from Arduino Connected to Mains.
  • Measured Vin when connected via USB & Mains (4.7V consistent).
  • Measured Current draw across both.
  • Compiled the Code with just the library, as well as with the demo code.
  • Changed Env settings to change upload frequency. as well as other relevant settings.

Ivan said this board in a previous thread has current problems, This would be the first time running into them as both boards are tested and working with other sources.
Googling suggests ESP32 brownout code if the problem is power draw. (because it starts with ets i wonder if maybe this is being cut out of the serial message somehow?)

Will attempt a non WROOM based ESP-Cam Module tomorrow (32S).

Any advice is appreciated.

Found a 30 Pin Equivalent Board - Still the same DoIt Dev Board.
Attempted to flash it with the same error code persisting.

Purchase of ESP-32-WROOM-32D Boards to replicate exact Chip used in Magnolia. Will update when i have tested these also.

Hi,
The mentioned Error message looks like the standard message when ESP32 restarts because it has failed to boot, there can be multiple causes of that, but with IoTaaP OS, the most common is that the SD card is not properly loaded or configured. Sice the system cannot start or boot without proper SD card filesystem.

Please check the details here for the hardware connection: Hardware - IoTaaP OS

and here for File structure on the SD card: SD Card - IoTaaP OS

1 Like

Thank you for the response,
I have attempted my best to follow those documents to the letter.

Current configuration is the following.
Development Board Connected to MicroSD Card Adaptor.

D and GPIO pin are the same.
Pin D5 → CS
Pin D19 - > MISO
Pin D23 → MOSI
Pin D18 - > SCK
3.3V → 3.3V
GND → GND

The MicroSD card is a brand new Sandisk 16GB Card. Tested and fully working.
File Structure extracted via direct download into Card through Card Reader.
I then added Console and Wifi data to CFG’s. I have emailed Ivan a copy of the SD card.

I will test the MicroSD reader further and with another similar model.

Any further suggestions are appreciated.

1 Like

Solution Found!

Thread can be closed.

Solution - MicroSD Card Reader Purchased with description of 3.3V VCC. The case is actually that it requires 5V to drive the Reader.

So any attempt ran into not having a working SD, as the reader wasn’t receiving enough voltage to turn on and recognise the SD Card.

Please note although Vin should be around 5V, It wasn’t quite enough to deliver enough to drive the MicroSD and the dev board at 5V.
Current work around was to hookup an Arduino Uno and Power the Vcc of the MicroSD Card adaptor to the Arduino 5V.

Hi Alex,
I’m glad to hear that it works!

Due to similar issues with other generic modules, we have developed IoTaaP Magnolia boards and Add-on boards.